Migrer vers PHP 5.2.10 sur CentOS (en utilisant YUM)

De Wikistrea

Par défaut sur CentOS5, la version de php est 5.1.x. Donc si vous désirez mettre à jour php , pou utiliser PhpMyadmin par exemple, il vous faudra migrer vers la version 5.2 (au minimum).

Il est possible de trouver aujourd'hui (mai 2011) une version 5.2.11 de php sur les environnements de test de CentOS, il est donc relativement facile de trouver les mises à jour et de les installer avec YUM. Il vous faudra donc, installer la clé GPG de environnement de test puis downloader les fichiers php5.2.10 de l'environement de test et enfin installer (via yum) la version téléchargée. Voici les commandes à utiliser (vous devez être loggé en tant qu'utilisateur root) :

>rpm --import http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
>cd /etc/yum.repos.d
>wget http://dev.centos.org/centos/5/CentOS-Testing.repo
>yum --disablerepo=* --enablerepo=c5-testing update php


Vous pouvez vérifier la version de php en tapant la commande : php -v

Contacter un technicien de SESTREA